2,159 Comments

  1. Hi Carlton
    How do I rotate the SW-R671 Di2 2×10/11-speed Remote 2 button shifters

  2. Can I replace my rear derailleur (9070)di2 with the latest type dura ace one I’m trying to fitt 30t cassette and can’t on present system

    1. Yes, but why not opt for the Ultegra RD? That will give you the option of 34t AND save you $.

      1. Wasn’t sure if these were fully compatible had actually thought a bought it .OK thanks for the advice I’m on it ..

    2. @Liam Buckley …above comment now several months past….same question pretty much…Have you gone down this road with the Ultegra RD and if so what feedback? I’m considering the DuraAce rd9150 for the same reasons. I have been able to configure my existing fd9070 to work with an 11-30t set but cannot get my E-Tube (3.3.3) to recognize this as a vaild configuration. Since the 9150 now retails (in Germany) at almost €500 it’s a serious consideration. Finally @Carlton am I correct in assuming that anything that is listed as a valid configuration in the E-Tube compatibility charts will work…meaning just swapping out the rear derailleur without having to also change the shifters. In summary will ST-9070L/R work with RD-R9150 without problem…

  3. Hi , is using SM-BTC1 + BTR2 compatible with R8050 ?
    does using SM-BTC1 eliminate the need for junction B in this case ?

  4. Hi Carlton
    I have a C-dale Synapse with ST-R785 Di2 levers (the first iteration of Shimano’s di2 hydraulic lever)
    i would like to be able to add some TT extensions with the TT Di2 shifters on the ends.
    Can I swap my 3 port junction for a 5 port junction box and add the shifters in?

    thanks
    Nathan

  5. Hi Carlton. I keep getting a dead Di2… I cycle somewhere then leave the bike for a coffee for a bit then when I get back to the bike the gears are dead. I have to unplug the battery to reset. I wondered if this was due to heat – I think it happens when the bike is left on a hot day …. any thoughts would be much appreciated!

    1. a bit more on this – this morning I put my bike in direct sunlight and left it for 30 minutes – gears were working before trying this. Then after 30 minutes the gears were dead. I was thinking this might be the Bluetooth module so removed that, waited for the bike to cool down and the gears to work again and then left the bike in the sun again. Gears dead again.
      I plugged the bike into my laptop and got etube running which showed that the shifters weren’t recognised but everything else was. Have you ever come across a problem like this? Seems to be related to heat and the connections from the and including the junction box to the shifters…
      DI2 – R9170 components throughout. Any thoughts?

      1. Author

        Great troubleshooting! This is very odd. All of the components should work fine at common temperatures. It’s unlikely that both shifters are not working properly at the same time. So it’s more likely a cable or an A-junction. I would get an extra Etube cable and start disconnecting components/cables and connecting them directly with an external cable to isolate the bad component.

      2. I had a problem some months ago, but put it down to cold. I always left my battery go down to flashing red. Used the same charger (Mar 2015) to charge up. Same garage and around the same yearly temperatures. This spring I went out, indicator was flashing green. 30km into a 65km cycle, front derailluer went to small chain ring. Charged up once home. Within two or three weeks, the same thing happened again. I had a new cable cut in half and four 4mm multi meter test sockets inline. I checked the voltage drop each day at around the same time for about two weeks. Each day it dropped around 0.07 Volts. I remember I was ok on the bike on Good Friday, a 130km cycle with a few front derailluer shifts and the drop for that ride was only 0.03 Volts. I also checked each derailluer movement loading and using a Fluke ma grip on clamp meter, got around 9mA per shift. I thought the front derailluer would be more as that is the one that would remove your finger from your hand. I then removed the seat post and got the same results, 0.07Volt drop per day……New battery required. I changed my charger and have no problem since. I always charge now on flashing green. I have always been care full where I park the bike and watch where the buttons are resting….. One final point, I always park up on the small chain ring.Why, just in case the system thinks the voltage is low and wants to change down, I don’t want it happening in my garage and the chain pulling across the chain ring for a few days. I have more info, but traveling at the moment. I can send it on in excel/ Word doc.

  6. Small question , about Full syncro mode , it allows automatic control of FD when i move up or down the cassette , but does it also allows auto. control of RD when i move between crank rings “like in semi-syncro mode”

  7. Hi,
    just bought a frame with Di-2 pre-installed.
    Brand new R8050 mechs now fitted =by me during assembly.

    I have not had an opportunity to view the set up on the Ipad, but I notice that the rear mech is working 11 speeds whilst on the small ring, but only 9 when on the big ring.
    The previous frame owner (semi-pro triathlete) had not set up Synchro (I have tried double/triple clicking the A-Junction)

    Has anyone seen this operation before ??

    1. Morning Stephen

      On my bike it is the other way around, namely, when in the small chainring the RD will not shift onto the two smallest cassette sprockets. According to the Shimano Dealer Manual this is deliberate and part of normal operation, presumably to avoid extreme chain angles. I have not set up syncro or semi syncro shifting but have my system on M (manual mode so I’m using both shifters)

      1. Thanks for the reply. The avoidance of extreme chain angles makes sense, and the risk of the chain jumping onto the big ring without warning.

        I will have a closer look into this on this bike and my other bike which has 6870 fitted (with Synchro).

        I certainly note that my Synchro (rear) works it’s way through the ratios so that there are effectively only 16 gears in use. It does still allow me to force the front mech across.

        1. Hi Stephen I too have 6850 on another bike but that limiting feature was not present – I think it is a new feature to the R8000 series, maybe because the RD cage is brought slightly inboard. The only other difference which may have a bearing is that my 6850 has a short cage whereas my R8050 has a medium cage

  8. Hi Carlton,

    Sorry in advance for this long-winded post but I need some help with my Ultegra Di2 RD 6870. I washed the bike after a particularly dusty ride a few weeks ago and since then my RD has stopped working. Ive tried a whole bunch of things:

    1.) Initially, i thought it was water damage, so i left it to dry in the sun…nope.
    2.) Then i thought maybe i should connect it to e-tube and see whats up: everything (including the gear position unit near the RD) gets recognised, but it cant find the RD.
    3.) I noticed my battery was also dying every 2 days or so, so i took out the battery and put a spare one on. Same result…so its not the battery.
    4.) I turned my attention next to the cables and junction box near the BB…thinking that maybe some water got pooled in the JB terminals and caused a shortage. So i took out my BB and played around with the JB swapping the cables. Again, RD doesnt work but all the JB terminals do.
    5.) RD cable. Next i connected my RD to the cable entering the FD, because the FD works fine. No dice. RD still doesnt work, so its not the cables.
    6.) Crash mode. Here’s one thing i’ve not been able to try. I noticed that when I press the button on my control box SM-EW90 junction, i cant get it to turn on calibration mode (solid red light). However, when i press the buttons on the shifter to check battery level, i can get the green and red lights showing the correct battery status. I havent been able to figure this out…the button on the JB essentially doesnt do anything. I hadnt needed calibration mode before this hiccup so i dont know if the button has always been faulty or it happened because of the wash.
    Even if it entered crash mode, i thought the RD would shift to the easiest gear automatically? Right now its stuck dead 3 gears from the easiest.
    7) Last, i havent been able to check the voltages heading to the derailleur or out of the battery. As soon as I connect the RD, the battery dies within 2 days, otherwise, it stays solid green after charging. Do you think this is the next step to take?

    I dont have a SM-PCE1 tool to directly connect the RD to e-tube, but with a normal e-tube connection via SM-EW90, i can see all the components except the RD…so I know the EW90 is also working fine! Unfortunately, im in a place where there are no LBS’s nearby that can diagnose or look at Di2 components, so im on my own here.

    Help! I didnt expect the RD to be dead after a few mins of water spraying when i’ve ridden through much worse conditions on the road!!

    1. Sorry for the double post.

      I have had this issue and here is my tuppence worth.

      Diagnosis via the PCE1 is the best way to go, almost always, though even that can lead you astray if your battery is not adequately charged.
      For example, if your battery is not adequately charged the PCE1 can simply list that the system will not work without certain components, even if they are all present and correct.

      I recovered from a similar scenario to yours by simply making sure the battery was fully charged before moving forward. I used two batteries and both needed topped up! Yep, silly, but that was it.

      If fully charged batteries fail to resolve the issue, [assuming you are not simply following procedures to exit emergency/crash mode] then you want to PCE1 diagnose your RD [directly] and check all is up to date and error free.

      Enjoy Di2. We love it!

      1. Thanks James. Unfortunately, i’ve also tried that. I’ve charged the batteries for 8-12 hours at a time (more than their recommended 2-4 hrs) because everytime i connect the RD, the battery dies within a day…without the RD, it keeps going without problems. I’ll try it again anyway…thanks.

  9. I have had this issue and here is my tuppence worth.

    Diagnosis via the PCE1 is the best way to go, almost alway, though even that can lead you astray if your is not battery adequately charged.
    For example, if your battery is not adequately charged the PCE1 can simply list that the system will not work without certain components, even if they are all present and correct.

    I recovered from a similar scenario to yours by simply, making sure the battery was fully charged before moving forward. I used two batteries and both needed topped up!

    If fully charged batteries fail to resolve the issue, [assuming you are not simply following procedures to exit emergency mode] then you want to PCE1 diagnose your RD [directly] and check all is up to date and error free.

    Enjoy Di2. We love it!

  10. I have a Dura Ace dI2 and the rear derailleur has stopped working. I recall there was a clicking noise before it stopped. I have replaced the external battery but this hasn’t helped. I have swapped rear and front mech cables and the rear shifter will work the front derailleur. The rear derailleur will automatically shift in protection mode but then will not work with the shifters. Any further ideas would be much appreciated.
    Thanks
    Marcus

    1. Author

      Your best bet is to use the PCE1 computer tool for full diagnostics. Short of that, it seems like you have a failed rear derailleur. So you can either use the PCE1 to do a full diagnostic, or get a new rear derailleur.

      1. Author

        It sounds like you have a failed rear derailleur. If it has the same problems when connected via a different wire (i.e. the front derailleur wire), then you can rule out cables and assume it’s the derailleur that is failed. You can probably confirm via the PCE1, or you can get a new rear derailleur and see if that fixes it.

  11. So to adjust the auto trim on the front derailleur when in the 6th gear you enter adjustment mode on the big\big then move to the small ring and 6th on the rear and make the trim adjustments? Is that how it works as I’m having a slight rub on outer edge of FD.

    1. Hi all, just a quick question, has this happen to anyone before. My external battery support suddenly stopped working. Below I describe what happened.
      I have had DI2 for ages, with no real problems. I have be racing and training with for the past 3 years (55,000km+) in this set up 10sp front derailluer with a 11sp rear derailluer and I have not had a single problem as I have never bothered doing any updates(as I know about the bug issue). But last weekend in a race a guy crashed into me breaking my rear derailluer. So I bought the same 11sp derailluer again. I fitted to the bike and it all worked fine for about 5mins, then I put it in to the adjustment mode and then all of a sudden the bike just shut down. Nothing at all, no lights, no front or rear derailluer working. So I connected the SM-PCE1 and it found all the items (it obviously comes up that the front and rear derailluer are not compatible- but we know this not to be true). The only thing it did not find is the external battery support. So I tried connecting this direct still it was not showing it was connected. So it is possible that the new derailluer can send a bug to stop the battery support working. If so how? And if I buy a new battery support and new front derailluer will it work?
      Many thanks for any help with this matter.

  12. Hi
    I have what I thought was a simple problem, but can’t find answers anywhere.
    I have a Di2 system with BT-DN110 battery and D-fly EW-WU111. It works fine with synchro shifting and all and deliveres info to my Garmin 1000 on which gear combination I’m in. Now I have changed the rear cassette from 11-28 to 11-30 but it still displays gear combinations on my Garmin as if I had 11-28. I can change the gear numbers on the Garmin to 11-30 but after a few seconds the D-fly overwrites it back to 11-28. In the E-tube program I don’t get the 11-30 option – only 11-25, 11-28, 12-25, 12-28, 11-23, 14-28. I guess it doesn’t have any impact on the actual shifting – seems to work fine, but it annoys me to get a wrong gear number reading on the Garmin.
    Thank you in advance.

    1. You have told E-Tube that you are using a RD-6870 SS rear mech. You need to change this to the GS version. This will then give you the 11-30 option.

      1. Hi Stephen
        Thanks for your quick reply. My rear derailleur is a RD-9070 SS and E-tube recognizes it automatically. When I try to change it to 6870 GS I can see options which ao. gives 11-30, but when trying to save it says: “unable to recognize unit RD-6870-GS.

        1. That is because Shimano don’t think the short cage RD works with a 30 tooth sprocket! 🙂

          1. But it does So I just have to live with the wrong info on the Garmin? Seems too expensive to buy a new derailleur just to get the right reading on the Garmin
            Thank you. I am very impressed by your quick response and looking forward to following the blog in the future.

  13. So glad for your page. Using almost exclusively the information here, I upgraded my tt to di2 and haven’t looked back. Now I’m getting ready to build a new bike up over the course of the next year, and was planning to do dura ace di2, but after finding out that the bar end shifters for DA are single control and everything relies on synchro shifting, I’m having second thoughts. I’d love to know what you think about it – you know how we humans are about change. I’m okay doing an ultegra build – just finally was at a point in my life where DA was an option if I build slow. And I’m just not sure how I feel about ONLY having the option of the synchro shifting. Thanks in advance

    1. Author

      For Ultegra vs. Dura-Ace, that’s more of a personal and financial decision. The two are extremely similar.

      For SyncroShift and the number of buttons on the bar-end shifters, that’s a separate decision from Ultegra vs. Dura-Ace. All shifters are compatible with all derailleurs. For me, given that the pricing is about the same, it would definitely get 2 of the 2-button shifters instead of 2 of the 1-button shifters. If you want to go pure SyncroShift control, just use the rear derailleur shifter or program both to be rear derailleur shifters. If you decide you want front derailleur control occasionally, then use the second shifter only when you need it. And if you decide you hate SyncroShift, you can turn it off completely using the PC or Smartphone software and still have all the buttons you need.

      I do not like the single button bar-end shifters. If I only wanted 2 buttons for exclusive SyncoShift, then I would order a single 2-button shifter and use a bar plug in the other location. This would save both cost and weight.

      1. I have a 2015 bike with 6870 DI2. I see a Dura ace RD9150 SS for sale. Is this work with mu DI2 system and will the cable connect ok.

  14. Fantastic post and really helpfull, thanks alot. One question, do you know if you can connect two right hand levers to one di2 setup, den reprogram one of them to serve as a left lever? I don’t care about mounting the acctual levers I just need the electronics inside for a DIY TT setup. I theory this could work, since you can program the levers to do pretty much whatever, but my concern is that the whole system might protest when there is two right levers connected?

    1. Author

      You should be able to use 2 right levers at the same time. You would need to connect them individually when configuring them with the Etube software, but after initial configuration, they should both work on the same bike at the same time. I haven’t tried this myself, but have seen it mentioned by others. Please let us know how it goes.

  15. Managed to lose the wireless / Wifi signal whilst updating the firmware to my DN100 battery holder, so effectively “bricked it” (as I believe the term). Tried updating again but no joy after 2 hours.
    I have dropped the DN100 off at the local bike shop as they have the SM-PCE1 and should be able to do the firmware by hard wire.

    NOW………since I have a MAC computer, is there any point buying a PCE1 ?? Have Shimano come out with E-Tube for Mac yet ??? (I suppose I could “borrow” a Windows PC from the kids)

    Would I actually NEED a PCE1 ??? I do have a SM-BCR2 charger as well. Could I use that instead ??

    1. Author

      I installed Windows via Bootcamp on my Mac to address those “hardware utilities only works with Windows” scenarios.

      You probably could have recovered the battery using the SM-BCR2 on a Windows computer. In E-tube for Windows, there is a separate icon that shows just a wire symbol. It is on the far right of the screen. You select the type of bike you are connecting to, then pick a device-type (i.e. battery) and manually apply the firmware update. (The PC cable must be connected to just that one device.)

      1. I took the DN100 to my local bike shop and they hooked it up to a PCE1 and sorted it.

        I was considering buying my own PCE1…..but then remembered I don’t have a Windows computer !! (Just Apple)

  16. Hi Carlton, I have a TT setup with single bar end shifters set up by dealer. On first ride I found the synchro shift doesn’t work and I’m stick in big ring. All components register on E tube and synchro shift is selected and FD will micro adjust with rear cassette chain movement but chain won’t move to small ring as it’s supposed to. Bike shop say bring it back for analysis but that’s a days drive away. Any assistance would be much appreciated. Thanks

    1. Author

      I’m wondering if the gearing needs to be configured in etube. That has to be done so the appropriate gear ratio transitions occur. I haven’t had to do that, so I don’t have details…

      1. I suspect that you need to tell E-tube what gearing you are using, and also when you want the shifting of the front to occur.

        You do also need to ensure that you have synchro assigned to at least one of the modes of the A-Junction. (It will not do synhcro mode if it is not in Synchro !!).

        Another option you can do is to fit and hide a SW-R600 climbing shifter which can operate the front mech. Quite handy to have this if you are facing a hill climb and you know you need the granny-ring !!

  17. I have a 2015 Focus Cayo 2.0. It has 6870 DI2 groupset on it. If in the future I need to replace parts, can I use a R8050 rear derailleur instead of the 6870, the same with the front derailleur. The main part that I might want to change is the front crankset, I know the R8000 has about 0.4mm less difference between both chain rings. can this work ok with my FD-6870 front derailleur ?

    1. Author

      As long as the derailleurs have the same number of speeds/gears, they should be compatible. I don’t think you need to replace your front derailleur to switch the front crankset. There’s plenty of adjust-ability and 0.4 mm is negligable and could easily be accounted for in trim settings. The only reason to switch rear derailleurs is to go from 10-sprockets to 11-sprockets, or from a shorter cage to a longer cage to accommodate larger rear sprockets.

      1. The reason I would be changing the rear derailluer, would be if it stopped working or was damaged, then it would be, get an 6870 or the newer 8050 which may be more easier available at that time.

  18. Hi C
    I have some different parts home since earlier and try to get a set working for one of the bikes in the for the family and it seem to be working but I do not have an extra charger for a SM-BTR1 battery (BCR1) but I have one BCR2 and the the bike do have a EW90 connector will this work with a BMRx or DN100?
    (This bike (owner also) will most likely move from home and need to possibility to charge)

    1. Author

      The charger for the internal battery will not charge the external battery, if that is what you are asking. The charger port on the 5-port Junction A only works on the internal battery.

  19. I would like to confirm a few things before trying to update a system with an external battery.

    1. The bike has the 5 port A junction – not the old style with integral cables. Nothing to change.

    2. The original battery mount needs to be replaced with a BM-DN100.

    3. The part that isn’t totally clear, some web sites indicate the “brains” are in the battery. Yet the Shimano compatibility page indicates the current external battery is the SM-BTR1. Will my SM-BTR1 from 2015 work?

    4. From the Shimano compatibility page there appears to be two Ant/Bluetooth transmitters: EW-WU101 and EW-WU111. Are there any functionality differences?

    5. Is there any reason other than not having an external battery to change to an internal battery?

    1. Author

      From what I recall about the external battery, the “brains” are in the battery mount, not the battery. For the internal battery, they are in the battery. So your external battery should work in in the new mount.

      From what I can tell, EW-WU101 and EW-WU111 are functionally the same.

      The reason for the internal battery vs. external is mostly aesthetics, and perhaps a tiny bit more water protection.

  20. Any chance you can update the download link for E-tube_Proj_V_2_5_2.exe? Thanks!

  21. Hi,

    Can the new bar end shifters SW-R9160 be used on a 6870 road setup (with the old internal battery from 2016, no synchro shift), connecting them directly to a SM-EW90-B junction (the one with 5 connectors) to shift the rear derailleur, just like the SW-9071 shifters?

    I’ve read that they’re only compatible with the 9050 road STI, and you also refer they that “These shifters require the BT-DN110 Internal Battery for synchronized shifting.”, but what if I want to use them just as normal shifters, like the SW-9071, one goes up the cassete, the other goes down. Nt possible?

    Thanks for your help!

    RP

    1. Author

      They should be compatible as long as everything has the latest firmware. They use the standard shit commands.

    2. I did that combo on my Madone 9. It works flawlessly.

    3. Thank you both for your answers!

  22. Hi, Thanks in advance for all your help. I’m still a little confused.
    I am currently running a bike with all the original old 6770 components, with the external battery, and the old SM-EW67 junction box, and everything is still working perfectly.
    I recently purchased the new R8050 FD and RD and an 11 speed cassette. I stupidly thought everything would be plug and play as i was replacing both FD and RD together, but when I did this, nothing worked.
    So I went to the local bike shop here (Chiang Mai) and he was able to update the software to the latest version, (the software had never been upgraded on the bike since purchasing it) but he said in order for the RD and RD to work, I will need to replace the front junction box also? Is this info correct? And therefore I will need two extra connecting wires to connect the new SM-EW90-A? Will my new shiny R8050 FD and RD work then?
    Thanks again!

    1. Author

      That is correct. The old junction does not work with newer components.

    2. I use a 6770 Front Derailleur with an 11 Sped RD 6870 and the EW67A Junction – that work flawless – subject to the condition the you downgrade the firmware.

      1. Hey JurIJ, Do you have an internal or external battery? Thanks!

  23. I have 6870. I see where I can pick up a spare set of levers, I was thinking of getting them as I have worn the coating off the levers and If I see or drop it , I would be ready to go. The other idea is wait and fit a set of the 8050. Will this work and I see they have hidden buttons under the hoods, what are these for ?

  24. Is there any reason I can’t use a JC-40 (external) junction B as an internal junction B.

  25. I have a new Focus Paralane Di2 and I added the EW-WU111 BT module. Downloaded the E-Tube app to my phone. It all hooks up and recognizes all the components. Updated all firm ware ok. The problem is that the system shows the standard cage SS rear derailleur when I have the long cage GS model, so the rear cluster choices do not include my 11/34 rear cluster. Any idea how to correct this?

    1. Author

      Steven,

      Sorry to hear about your issue. I haven’t run into this issue before. My best guess is that it’s an app issue. The Etube windows software may correctly recognize the derailleir and it’s capabilities. I would try that, or submit a big report to Shimano and wait…

      1. Thanks for your reply. After looking at the rear cassette closer I found that Focus installed an 11/30 and not the advertised 11/34. So they used the SS mid cage rear derailleur as a result. This bike was brand new in the factory sealed box, so it was apparently a production change for whatever reason.

    2. Perhaps yours is actually the short cage model…and a previous owner has fitted the long cage to it ??

  26. A friend of mine bought a S-works Tarmac second hand, great bike but geared for a pro. He has short body so if I change the front crankset from 53/39 to 52/36, will the Dura ace 9070 di2 front derailleur still do with the smaller rings. if I want to put a large range cassette in the back(CS-R8000, 11/30 or 11/32) can I put a 6870 med cage on the Dura ace RD or chamge the rear derailleur to a 6870 or a newer R8050 with the longer cage?

    1. Author

      All of the 11-speed compatible derailleurs are interchangeable. You just can’t use older 10-speed versions.

      1. The front mech will have no problems with a 52/36 or even a 50/34, the same mech does them all, you may need to adjust the position on the seat tube of the mech if its a long way out, the bottom of the mech should be just clear of the teeth, you can make your own guide from your present set up!

        1. Has anyone put a GS cage on a RD-9070 from a ultegra 6870?

Leave a Reply to SteveP4 Cancel reply